openSUSE Security Update : libqt5-qtbase / libqt5-qtdeclarative (openSUSE-2017-731)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update for libqt5-qtbase and libqt5-qtdeclarative fixes the
following issues :

This security issue was fixed :

- Prevent potential information leak due to race condition
in QSaveFile (bsc#1034005).

These non-security issues were fixed :

- Fixed crash in QPlainTextEdit

- Fixed Burmese rendering issue

- Fixed reuse of C++-owned QObjects by different QML
engines that could lead to crashes in kwin (bsc#1034402)

- Make libqt5-qtquickcontrols available in SUSE Linux
Enterprise.

This update was imported from the SUSE:SLE-12-SP2:Update update
project.

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=1013095
https://bugzilla.opensuse.org/show_bug.cgi?id=1034005
https://bugzilla.opensuse.org/show_bug.cgi?id=1034402

Solution :

Update the affected libqt5-qtbase / libqt5-qtdeclarative packages.

Risk factor :

Medium

Family: SuSE Local Security Checks

Nessus Plugin ID: 101132 ()

Bugtraq ID:

CVE ID:

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now