openSUSE Security Update : libmicrohttpd (openSUSE-2017-728)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update for libmicrohttpd fixes the following issues :

- CVE-2013-7038: The MHD_http_unescape function in
libmicrohttpd might have allowed remote attackers to
obtain sensitive information or cause a denial of
service (crash) via unspecified vectors that trigger an
out-of-bounds read. (bsc#854443)

- CVE-2013-7039: Stack-based buffer overflow in the
MHD_digest_auth_check function in libmicrohttpd, when
MHD_OPTION_CONNECTION_MEMORY_LIMIT is set to a large
value, allowed remote attackers to cause a denial of
service (crash) or possibly execute arbitrary code via a
long URI in an authentication header. (bsc#854443)

- Fixed various bugs found during a 2017 audit, which are
more hardening measures and not security issues.
(bsc#1041216)

This update was imported from the SUSE:SLE-12:Update update project.

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=1041216
https://bugzilla.opensuse.org/show_bug.cgi?id=854443

Solution :

Update the affected libmicrohttpd packages.

Risk factor :

Medium / CVSS Base Score : 6.4
(CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 101130 ()

Bugtraq ID:

CVE ID: CVE-2013-7038
CVE-2013-7039

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now