Tenable SecurityCenter PHP < 5.6.26 Multiple Vulnerabilities

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The Tenable SecurityCenter application on the remote host contains a
PHP library that is affected by multiple vulnerabilities.

Description :

The Tenable SecurityCenter application installed on the remote host
is missing a security patch. It is, therefore, affected by multiple
vulnerabilities in the bundled version of PHP :

- A flaw exists in ext/standard/var_unserializer.re when
destroying deserialized objects due to improper
validation of user-supplied input. An unauthenticated,
remote attacker can exploit this, via a deserialize
call that references a partially constructed object, to
corrupt memory, resulting in a denial of service
condition. (CVE-2016-7411)

- An heap buffer overflow condition exists in the
php_mysqlnd_rowp_read_text_protocol_aux() function
within file ext/mysqlnd/mysqlnd_wireprotocol.c due to
a failure to verify that a BIT field has the
UNSIGNED_FLAG flag. An unauthenticated, remote attacker
can exploit this, via specially crafted field metadata,
to cause a denial of service condition. (CVE-2016-7412)

- A use-after-free error exists in the
wddx_stack_destroy() function within file
ext/wddx/wddx.c when deserializing recordset elements.
An unauthenticated, remote attacker can exploit this,
via a specially crafted wddxPacket XML document, to
cause a denial of service condition. (CVE-2016-7413)

- An out-of-bounds access error exists in the
phar_parse_zipfile() function within file ext/phar/zip.c
due to a failure to ensure that the
uncompressed_filesize field is large enough. An
unauthenticated, remote attacker can exploit this, via a
specially crafted archive, to cause a denial of service
condition. (CVE-2016-7414)

- A stack-based buffer overflow condition exists in the
ICU4C library, specifically within file common/locid.cpp
in the the msgfmt_format_message() function, due to a
failure to properly restrict the locale length provided
to the Locale class. An unauthenticated, remote attacker
can exploit this, via a long first argument to a
MessageFormatter::formatMessage() function call, to
cause a denial of service condition. (CVE-2016-7416)

- A flaw exists in the spl_array_get_dimension_ptr_ptr()
function within file ext/spl/spl_array.c due to a
failure to properly validate the return value and data
type when deserializing SplArray. An unauthenticated,
remote attacker can exploit this, via specially crafted
serialized data, to cause a denial of service condition.
(CVE-2016-7417)

- An out-of-bounds read error exists in the
php_wddx_push_element() function within file
ext/wddx/wddx.c when handling an incorrect boolean
element, which leads to mishandling the
wddx_deserialize() call. An unauthenticated, remote
attacker can exploit this, via a specially crafted
wddxPacket XML document, to cause a denial of service
condition. (CVE-2016-7418)

- An out-of-bounds access error exists in the
phar_parse_tarfile() function within file ext/phar/tar.c
when handling the verification of signatures. An
unauthenticated, remote attacker can exploit this to
cause an unspecified impact. (VulnDB 144264)

- An integer overflow condition exists in the fgetcsv()
function when handling CSV field lengths due to improper
validation of certain input. An unauthenticated, remote
attacker can exploit this to corrupt memory, resulting
in a denial of service condition or the execution of
arbitrary code. (VulnDB 144270)

- An integer overflow condition exists in the wordwrap()
function within file ext/standard/string.c due to
improper validation of certain input. An
unauthenticated, remote attacker can exploit this to
corrupt memory, resulting in a denial of service
condition or the execution of arbitrary code.
(VulnDB 144271)

- An integer overflow condition exists in the fgets()
function within file ext/standard/file.c due to improper
validation of certain input. An unauthenticated, remote
attacker can exploit this to corrupt memory, resulting
in a denial of service condition or the execution of
arbitrary code. (VulnDB 144273)

- An integer overflow condition exists in the
xml_utf8_encode() function within file ext/xml/xml.c due
to improper validation of certain input. An
unauthenticated, remote attacker can exploit this to
cause an unspecified impact. (VulnDB 144275)

- A flaw exists in the exif_process_IFD_in_TIFF() function
within file ext/exif/exif.c when handling uninitialized
thumbnail data. An unauthenticated, remote attacker can
exploit this to disclose memory contents.
(VulnDB 144287)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

http://php.net/ChangeLog-5.php#5.6.26

Solution :

Upgrade to SecurityCenter version 5.4.1 or later. Alternatively,
contact the vendor for a patch.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 9.0
(CVSS2#E:POC/RL:U/RC:ND)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now