Fortinet FortiOS 5.2.x / 5.3.x / 5.4.x < 5.4.5 Multiple XSS (FG-IR-17-127)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote host is affected by multiple cross-site scripting
vulnerabilities.

Description :

The version of Fortinet FortiOS running on the remote device is 5.2.x,
5.3.x, or 5.4.x prior to 5.4.4. It is, therefore, affected by multiple
cross-site scripting (XSS) vulnerabilities :

- A cross-site scripting (XSS) vulnerability exists when
saving configuration revisions due to improper
validation of user-supplied input to comments before
returning it to users. An authenticated, remote attacker
can exploit this, via a specially crafted request, to
execute arbitrary script code in a user's browser
session. (CVE-2017-7734)

- A cross-site scripting (XSS) vulnerability exists when
creating or editing user groups due to improper
validation of user-supplied input to groups before
returning it to users. An authenticated, remote attacker
can exploit this, via a specially crafted request, to
execute arbitrary script code in a user's browser
session. (CVE-2017-7735)

See also :

http://fortiguard.com/psirt/FG-IR-17-127

Solution :

Upgrade to Fortinet FortiOS version 5.4.5 or later.

Risk factor :

Low / CVSS Base Score : 3.5
(CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N)
CVSS Temporal Score : 2.9
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Firewalls

Nessus Plugin ID: 100998 ()

Bugtraq ID: 99098

CVE ID: CVE-2017-7734
CVE-2017-7735

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now