Apache 2.2.x < 2.2.33-dev / 2.4.x < 2.4.26 Multiple Vulnerabilities

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote web server is affected by multiple vulnerabilities.

Description :

According to its banner, the version of Apache running on the remote
host is 2.2.x prior to 2.2.33-dev or 2.4.x prior to 2.4.26. It is,
therefore, affected by the following vulnerabilities :

- An authentication bypass vulnerability exists due to
third-party modules using the ap_get_basic_auth_pw()
function outside of the authentication phase. An
unauthenticated, remote attacker can exploit this to
bypass authentication requirements. (CVE-2017-3167)

- A NULL pointer dereference flaw exists due to
third-party module calls to the mod_ssl
ap_hook_process_connection() function during an HTTP
request to an HTTPS port. An unauthenticated, remote
attacker can exploit this to cause a denial of service
condition. (CVE-2017-3169)

- A NULL pointer dereference flaw exists in mod_http2 that
is triggered when handling a specially crafted HTTP/2
request. An unauthenticated, remote attacker can exploit
this to cause a denial of service condition. Note that
this vulnerability does not affect 2.2.x.
(CVE-2017-7659)

- An out-of-bounds read error exists in the
ap_find_token() function due to improper handling of
header sequences. An unauthenticated, remote attacker
can exploit this, via a specially crafted header
sequence, to cause a denial of service condition.
(CVE-2017-7668)

- An out-of-bounds read error exists in mod_mime due to
improper handling of Content-Type response headers. An
unauthenticated, remote attacker can exploit this, via a
specially crafted Content-Type response header, to cause
a denial of service condition or the disclosure of
sensitive information. (CVE-2017-7679)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

https://archive.apache.org/dist/httpd/CHANGES_2.2.32
https://archive.apache.org/dist/httpd/CHANGES_2.4.26
https://httpd.apache.org/security/vulnerabilities_22.html
https://httpd.apache.org/security/vulnerabilities_24.html

Solution :

Upgrade to Apache version 2.2.33-dev / 2.4.26 or later.

Risk factor :

High / CVSS Base Score : 8.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:C)
CVSS Temporal Score : 7.0
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 100995 ()

Bugtraq ID: 99132
99134
99135
99137
99170

CVE ID: CVE-2017-3167
CVE-2017-3169
CVE-2017-7659
CVE-2017-7668
CVE-2017-7679

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now