Ubisoft uPlay < 2.0.4 Browser Plugin RCE

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

A game launcher application installed on the host is affected by a
remote code execution vulnerability.

Description :

According to its version number, the Ubisoft uPlay application
installed on the remote host is prior to 2.0.4. It is, therefore,
affected by a remote code execution vulnerability in the web browser
plugin due to improper validation of user-supplied input passed via
the '-orbit_exe_path' command line argument. An unauthenticated,
remote attacker can exploit this, via a specially crafted website, to
execute arbitrary code.

See also :

http://www.nessus.org/u?6ce2b92c
http://seclists.org/fulldisclosure/2012/Jul/375

Solution :

Upgrade to Ubisoft uPlay version 2.0.4 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.7
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 100961 ()

Bugtraq ID: 54867

CVE ID: CVE-2012-4177

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now