Adobe Digital Editions < 4.5.5 Multiple Vulnerabilities (APSB17-20) (macOS)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

An application installed on the the remote macOS or Mac OS X host is
affected by multiple vulnerabilities.

Description :

The version of Adobe Digital Editions installed on the remote macOS or
Mac OS X host is prior to 4.5.5. It is, therefore, affected by
multiple vulnerabilities :

- Multiple memory corruption issues exist due to improper
validation of user-supplied input. An unauthenticated,
remote attacker can exploit these to cause a denial of
service condition or the execution of arbitrary code.
(CVE-2017-3088, CVE-2017-3089, CVE-2017-3093,
CVE-2017-3096)

- Multiple unspecified flaws exist related to insecure
loading of libraries. A local attacker can exploit these
to gain elevated privileges. (CVE-2017-3090,
CVE-2017-3092, CVE-2017-3097)

- Multiple stack-based buffer overflow conditions exist
due to improper validation of user-supplied input. An
unauthenticated, remote attacker can exploit these to
disclose memory contents. (CVE-2017-3094, CVE-2017-3095)

See also :

http://www.nessus.org/u?344c096d
http://www.nessus.org/u?c3aa2f29

Solution :

Upgrade to Adobe Digital Editions version 4.5.5 or later.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.4
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: MacOS X Local Security Checks

Nessus Plugin ID: 100793 ()

Bugtraq ID: 99020
99021
99024

CVE ID: CVE-2017-3088
CVE-2017-3089
CVE-2017-3090
CVE-2017-3092
CVE-2017-3093
CVE-2017-3094
CVE-2017-3095
CVE-2017-3096
CVE-2017-3097

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now