GLSA-201706-13 : minicom: Remote execution of arbitrary code

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201706-13
(minicom: Remote execution of arbitrary code)

In minicom before version 2.7.1, the escparms[] buffer in vt100.c is
vulnerable to an overflow.

Impact :

A remote attacker, able to connect to a minicom port, could possibly
execute arbitrary code with the privileges of the process, or cause a
Denial of Service condition.

Workaround :

There is no known workaround at this time.

See also :

https://security.gentoo.org/glsa/201706-13

Solution :

All minicom users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=net-dialup/minicom-2.7.1'

Risk factor :

Medium

Family: Gentoo Local Security Checks

Nessus Plugin ID: 100656 ()

Bugtraq ID:

CVE ID: CVE-2017-7467

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now