IBM Tivoli Federated Identity Manager 6.2.x < 6.2.2 FP17 Multiple Vulnerabilities

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote host has an application installed that is affected by
multiple vulnerabilities.

Description :

The version of IBM Tivoli Federated Identity Manager installed on the
remote Windows host is 6.2.x prior to 6.2.2.17. It is, therefore,
affected by multiple vulnerabilities :

- An information disclosure vulnerability exists due to a
failure to properly use Secure attributes in cookies. An
unauthenticated, remote attacker can exploit this to
disclose sensitive information. (CVE-2017-1319)

- A cross-site scripting (XSS) vulnerability exists due to
improper validation of user-supplied input. An
authenticated, remote attacker can exploit this, via a
specially crafted request, to execute arbitrary script
code in a user's browser session. (CVE-2017-1320)

See also :

https://www-01.ibm.com/support/docview.wss?uid=swg22002877
https://www-01.ibm.com/support/docview.wss?uid=swg22002871

Solution :

Upgrade to IBM Tivoli Federated Identity Manager version 6.2.2 FP17
(6.2.2.17) or later.

Risk factor :

Medium / CVSS Base Score : 4.0
(CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:N)
CVSS Temporal Score : 3.0
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 100422 ()

Bugtraq ID: 98480
98482

CVE ID: CVE-2017-1319
CVE-2017-1320

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now