VMware Workstation 12.x < 12.5.6 Insecure Library Loading Privilege Escalation (VMSA-2017-0009) (Linux)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

A virtualization application installed on the remote Linux host is
affected by a privilege escalation vulnerability.

Description :

The version of VMware Workstation installed on the remote Linux host
is 12.x prior to 12.5.6. It is, therefore, affected by a privilege
escalation vulnerability in the ALSA sound driver due to insecurely
loading shared libraries via the '.asoundrc' configuration file. A
local attacker can exploit this, by loading specially crafted
libraries, to gain root privileges on the host.

See also :

http://www.vmware.com/security/advisories/VMSA-2017-0009.html

Solution :

Upgrade to VMware Workstation version 12.5.6 or later.

Risk factor :

High / CVSS Base Score : 7.2
(CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.0
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: General

Nessus Plugin ID: 100417 ()

Bugtraq ID: 98566

CVE ID: CVE-2017-4915

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now