Fortinet FortiOS 5.0.x / 5.2.x < 5.2.11 'global-label' Parameter XSS (FG-IR-17-057)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote host is affected by a cross-site scripting vulnerability.

Description :

The version of Fortinet FortiOS running on the remote device is 5.0.x
or 5.2.x prior to 5.2.11. It is, therefore, affected by a stored
cross-site scripting (XSS) vulnerability due to improper validation of
user-supplied input to the 'global-label' parameter. An authenticated,
remote attacker can exploit this, via a specially crafted request, to
execute arbitrary script code in a user's browser session.

See also :

http://fortiguard.com/psirt/FG-IR-17-057

Solution :

Upgrade to Fortinet FortiOS version 5.2.11 or later.

Risk factor :

Low / CVSS Base Score : 3.5
(CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N)
CVSS Temporal Score : 2.9
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Firewalls

Nessus Plugin ID: 100384 ()

Bugtraq ID: 98514

CVE ID: CVE-2017-3128

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now