GLSA-201705-09 : Apache Tomcat: Multiple vulnerabilities

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201705-09
(Apache Tomcat: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in Tomcat. Please review
the CVE identifiers referenced below for details.

Impact :

A remote attacker may be able to cause a Denial of Service condition,
obtain sensitive information, bypass protection mechanisms and
authentication restrictions.
A local attacker, who is a tomcat’s system user or belongs to
tomcat’s group, could potentially escalate privileges.

Workaround :

There is no known workaround at this time.

See also :

https://security.gentoo.org/glsa/201705-09

Solution :

All Apache Tomcat users have to manually check their Tomcat runscripts
to make sure that they don’t use an old, vulnerable runscript. In
addition:
All Apache Tomcat 7 users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=www-servers/tomcat-7.0.70:7'
All Apache Tomcat 8 users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=www-servers/tomcat-8.0.36:8'

Risk factor :

High / CVSS Base Score : 7.8
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C)

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now