IBM WebSphere Application Server 7.0 < 7.0.0.45 / 8.0 < 8.0.0.14 / 8.5 < 8.5.5.12 / 9.0 < 9.0.0.4 / Liberty 17.0 < 17.0.0.2 OAuth Service Provider XSRF

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote web application server is affected by a cross-site request
forgery vulnerability

Description :

The version of IBM WebSphere Application Server running on the remote
host is 7.0 prior to 7.0.0.45, 8.0 prior to 8.0.0.14, 8.5 prior to
8.5.5.12, 9.0 prior to 9.0.0.4, or Liberty 17.0 prior to 17.0.0.2. It
is, therefore, affected by a cross-site request forgery (XSRF)
vulnerability in the OAuth service provider due to a failure to
require multiple steps, explicit confirmation, or a unique token when
performing certain sensitive actions. An unauthenticated, remote
attacker can exploit this vulnerability, by convincing a user to
follow a specially crafted link, to perform unintended actions.

See also :

http://www-01.ibm.com/support/docview.wss?uid=swg22001226

Solution :

Apply IBM WebSphere Application Server version 7.0 Fix Pack 45
(7.0.0.45) / 8.0 Fix Pack 14 (8.0.0.14) / 8.5 Fix Pack 12 (8.5.5.12) /
9.0 Fix Pack 4 (9.0.0.4) / Liberty 17.0 Fix Pack 2 (Liberty 17.0.0.2)
or later. Alternatively, apply the appropriate Interim Fixes as
recommended in the vendor advisory.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.0
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 100123 ()

Bugtraq ID: 98142

CVE ID: CVE-2017-1194

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now