GLSA-201705-05 : FFmpeg: Multiple vulnerabilities

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201705-05
(FFmpeg: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in FFmpeg. Please review
the CVE identifiers referenced below for details.
gst-plugins-libav is affected because this package is bundling a
vulnerable FFmpeg version.

Impact :

A remote attacker could entice a user or automated system using FFmpeg
to process a specially crafted file, resulting in the execution of
arbitrary code or a Denial of Service.

Workaround :

There is no known workaround at this time.

See also :

https://security.gentoo.org/glsa/201705-05

Solution :

All FFmpeg users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=media-video/ffmpeg-3.2.4'
All gst-plugins-libav users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose
'>=media-plugins/gst-plugins-libav-1.10.4'

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 100082 ()

Bugtraq ID:

CVE ID: CVE-2017-5024
CVE-2017-5025

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now