Apple iTunes < 12.6 Multiple Vulnerabilities (macOS) (credentialed check)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote host contains an application that is affected by multiple
vulnerabilities.

Description :

The version of Apple iTunes installed on the remote macOS or Mac OS X
host is prior to 12.6. It is, therefore, affected by multiple
vulnerabilities :

- Multiple vulnerabilities exist in the expat component,
the most severe of which are remote code execution
vulnerabilities. An unauthenticated, remote attacker can
exploit these vulnerabilities to cause a denial of
service condition or the execution of arbitrary code in
the context of the current user. (CVE-2009-3270,
CVE-2009-3560, CVE-2009-3720, CVE-2012-1147,
CVE-2012-1148, CVE-2012-6702, CVE-2015-1283,
CVE-2016-0718, CVE-2016-4472, CVE-2016-5300)

- Multiple vulnerabilities exist in the SQLite component,
the most severe of which are remote code execution
vulnerabilities. An unauthenticated, remote attacker can
exploit these vulnerabilities by convincing a user to
open a specially crafted file, to cause a denial of
service condition or the execution of arbitrary code in
the context of the current user. (CVE-2013-7443,
CVE-2015-3414, CVE-2015-3415, CVE-2015-3416,
CVE-2015-3717, CVE-2015-6607, CVE-2016-6153)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

https://support.apple.com/en-us/HT207598
http://www.nessus.org/u?8b01bc68

Solution :

Upgrade to iTunes version 12.6 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:ND)
Public Exploit Available : true