Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Mozilla Firefox < 3.0.16 / 3.5.6 Multiple Vulnerabilities

High

Synopsis

The remote host has a web browser installed that is affected by multiple attack vectors.

Description

The remote host is running a version of Mozilla Firefox earlier than 3.0.16 or 3.5.6. Such versions are potentially affected by multiple vulnerabilities :

- Multiple crashes that could result in arbitrary code execution. (MFSA 2009-65)

- Multiple vulnerabilities in 'liboggplay' which could lead to arbitrary code execution. Note that this only affects the 3.5.x branch. (MFSA 2009-66)

- An integer overflow in the 'Theora' video library which could lead to a crash or the execution of arbitrary code. Note that this only affects the 3.5.x branch. (MFSA 2009-67)

- The NTML implementation is vulnerable to reflection attacks in which NTML credentials from one application could be forwarded to another application. (MFSA 2009-68)

- Multiple location bar spoofing vulnerabilities. (MFSA 2009-69)

- A content window which is opened by a chrome window retains a reference to the chrome window via the 'window.opener' property which could lead to a privilege escalation. (MFSA 2009-70)

- The exception messages generated by the 'GeckoActiveXObject' differ based on whether or not the requested COM object's ProgID is present in the system registry. (MFSA 2009-71)

Solution

Upgrade to Mozilla Firefox 3.0.16, 3.5.6, or later.