Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Mozilla Firefox 3.6 < 3.6.20 Multiple Vulnerabilities

High

Synopsis

The remote host has a web browser installed that is vulnerable to multiple attack vectors.

Description

The remote host has a web browser installed that is vulnerable to multiple attack vectors.

Versions of Firefox 3.6 earlier than 3.6.20 are potentially affected by the following security issues :

- A dangling pointer vulnerability exists in an SVG text manipulation routine. (CVE-2011-0084)

. -A DOM accounting error exists in the 'appendChild' JavaScript function that can allow an invalid pointer to be dereferenced. (CVE-2011-2378)

- An error exists in 'ThinkPadSensor: : Startup' that can allow malicious DLLs to be loaded. (CVE-2011-2980)

- An error exists in the event management code that can allow JavaScript to execute in the context of a different website and possibly in the chrome-privileged context. (CVE-2011-2981)

- Various unspecified memory safety issues exist. (CVE-2011-2982)

- A cross-domain information disclosure vulnerability exists if the configuration option 'RegExp.input' is set. (CVE-2011-2983)

- A privilege escalation vulnerability exists if web content is registered to handle 'drop' events and a browser tab is dropped in that element's area. This can allow the web content to execute with browser chrome privileges. (CVE-2011-2984)

Solution

Upgrade to Firefox 6.0 or later.