1.15 - Ensure IBM JRE 1.6 is configured correctly - 'policy.provider = sun.security.provider.PolicyFile'

Information

When IBM JRE 1.6 is configured as the Java Runtime Environment, the following configuration changes must be made to ensure compatibility between JBoss EAP and IBM JRE. IBM JRE 1.6 uses a default policy provider which does not work correctly with the JBoss Enterprise Application Platform security policy. The IBM JRE must be reconfigured to use the standard policy provider.

Solution

Edit the file JAVA_HOME/jre/lib/security/java.security and set the value of policy.provider to sun.security.provider.PolicyFile

Item Details

Category: CONFIGURATION MANAGEMENT

References: 800-53|CM-6b., CAT|II

Plugin: Unix

Control ID: 55227d31ff6a7543b99fab52a6e0d8b309a89bc9737c4d38806bef8ea280741d