VCPG-67-000009 - VMware Postgres must limit modify privileges to authorized accounts.

Information

If the DBMS were to allow any user to make changes to database structure or logic, those changes might be implemented without undergoing the appropriate testing and approvals that are part of a robust change management process.

Accordingly, only qualified and authorized individuals must be allowed to obtain access to information system components to initiate changes, including upgrades and modifications.

Unmanaged changes that occur to the database software libraries or configuration can lead to unauthorized or compromised installations.

Solution

At the command prompt, execute the following command:

# /opt/vmware/vpostgres/current/bin/psql -U postgres -c 'REVOKE ALL PRIVILEGES FROM <user>;'

Replace <user> with the account discovered during the check.

See Also

https://dl.dod.cyber.mil/wp-content/uploads/stigs/zip/U_VMW_vSphere_6-7_Y22M04_STIG.zip

Item Details

Category: CONFIGURATION MANAGEMENT

References: 800-53|CM-5(6), CAT|II, CCI|CCI-001499, Rule-ID|SV-239202r678979_rule, STIG-ID|VCPG-67-000009, Vuln-ID|V-239202

Plugin: Unix

Control ID: d857498e98fe56c5a0590ad3e8051d603a5aac00dedb0c6168ff81ccb8836d61