PPS9-00-001100 - The EDB Postgres Advanced Server must allow only the ISSM (or individuals or roles appointed by the ISSM) to select which auditable events are to be audited.

Information

Without the capability to restrict which roles and individuals can select which events are audited, unauthorized personnel may be able to prevent or interfere with the auditing of critical events.

Suppression of auditing could permit an adversary to evade detection.

Misconfigured audits can degrade the system's performance by overwhelming the audit log. Misconfigured audits may also make it more difficult to establish, correlate, and investigate the events relating to an incident or identify those responsible for one.

Solution

Run these commands:

1) 'chown enterprisedb <postgresql data directory>/postgresql*.conf'

2) 'chgrp enterprisedb <postgresql data directory>/postgresql*.conf'

3) 'chmod 600 <postgresql data directory>/postgresql*.conf'

(The default path for the postgresql data directory is /var/lib/ppas/9.5/data, but this will vary according to local circumstances.)

See Also

https://dl.dod.cyber.mil/wp-content/uploads/stigs/zip/U_EDB_PGS_Advanced_Server_V2R1_STIG.zip

Item Details

Category: AUDIT AND ACCOUNTABILITY

References: 800-53|AU-12b., CAT|II, CCI|CCI-000171, Rule-ID|SV-213566r508024_rule, STIG-ID|PPS9-00-001100, STIG-Legacy|SV-83489, STIG-Legacy|V-68885, Vuln-ID|V-213566

Plugin: Unix

Control ID: ecb07539b15dc2c320ea719a32eb71e01c0bcc8b359d7849fe1c0c8caff4bf2d