Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Zend Framework < 2.4.11 RCE

Critical

Synopsis

The remote host is using a version of Zend Framework that is vulnerable to a Remote Code Execution (RCE) attack vector.

Description

Versions of Zend Framework earlier than 2.4.11 are exposed to a flaw that exists in the 'Zend\Mail\Transport\Sendmai' transport in the zend-mail component that is triggered as input passed via email addresses is not properly sanitized. This may allow a remote attacker to execute arbitrary commands.

Solution

Upgrade Zend Framework to version 2.4.11 or later.