Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

ISC BIND 9.x < 9.9.8-S5 / 9.9.9-S3 DoS

Medium

Synopsis

The remote DNS server may be affected by a Denial of Service (DoS) attack vector.

Description

Versions of ISC BIND 9.x prior to 9.9.8-S5 and 9.9.9-S3 are unpatched for a flaw in 'rdataset.c' that is triggered when handling flag values in incoming queries. This may allow a remote attacker to cause a REQUIRE assertion failure leading to termination of the service.

Solution

Upgrade ISC BIND to version 9.9.9-S3 or later. If version 9.9.x cannot be obtained, version 9.9.8-S5 is also patched for this vulnerability.