Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Samba 4.3.x < 4.3.13 / 4.4.x < 4.4.8 / 4.5.x < 4.5.3 Multiple Vulnerabilities

High

Synopsis

The remote host is running a version of Samba server that is affected by multiple vulnerabilities.

Description

Versions of Samba 4.3.x prior to 4.3.13, 4.4.x prior to 4.4.8, and 4.5.x prior to 4.5.3 are unpatched, and therefore affected by the following vulnerabilities :

- An overflow condition exists in the 'ndr_pull_dnsp_name()' function in 'librpc/ndr/ndr_dnsp.c' that is triggered when handling 'dnsRecord' attributes of DNS objects. With a specially crafted request, an authenticated, remote attacker can cause a heap-based buffer overflow, resulting in a denial of service or potentially allowing the execution of arbitrary code. (OSVDB 149000) - A flaw exists related to the client code always requesting a forwardable Kerberos ticket when performing Kerberos authentication. This may allow a service accepting the 'AP-REQ' from the client to perform the same actions as the client within the Kerberos TGT. (OSVDB 149001) - A flaw exists in the 'check_pac_checksum()' function in 'auth/kerberos/kerberos_pac.c' that is triggered when handling Kerberos PAC (Privilege Attribute Certificate) validation. This may allow an authenticated, remote attacker to corrupt memory and crash the winbindd process. (OSVDB 149002)

Solution

Upgrade Samba to version 4.5.3 or later. If version 4.5.x cannot be obtained, versions 4.4.8, and 4.3.13 are also patched for these issues.