Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

PHP 5.6.x < 5.6.28 / 7.0.x < 7.0.13 Multiple Vulnerabilities

Critical

Synopsis

The remote web server uses a version of PHP that is affected by multiple attack vectors.

Description

Versions of PHP 5.6.x prior to 5.6.28 and 7.0.x prior to 7.0.13 are vulnerable to the following issues :

- A flaw exists that is due to 'parse_url' returning the incorrect host. This may allow a remote attacker to have an impact that may include bypassing authentication, or conducting open redirection and server-side request forgery attacks, depending on how the function is implemented. (OSVDB 145227) - An integer overflow condition exists in the '_php_imap_mail()' function in 'ext/imap/php_imap.c' that is triggered when handling overly long strings. This may allow a remote attacker to cause a heap-based buffer overflow, leading to a crash or the potential execution of arbitrary code. (OSVDB 146957) - A flaw exists that is triggered when handling overly long strings passed to the 'bzcompress()' PHP method. This may allow a remote attacker to cause a denial of service. (OSVDB 146975) - An integer overflow condition exists in the 'gdImageAALine()' function in 'ext/gd/libgd/gd.c' that is triggered as line limit values are not properly validated. This may allow a remote attacker to cause an out-of-bounds write or read flaw, which may potentially allow the attacker to crash a process utilizing the language, disclose memory contents, or execute arbitrary code. (OSVDB 147321) - An infinite loop flaw exists in the 'exception::__toString()' function in 'Zend/zend_exceptions.c' that is triggered during the unserialization of self-referencing exception objects. This may allow a remote attacker to cause a denial of service. (OSVDB 149441)

Solution

Upgrade to PHP version 7.0.13 or later. If 7.x cannot be obtained, 5.6.28 has also been patched for these vulnerabilities.