Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

cURL/libcurl 7.x < 7.48.0 Unknown Vulnerability

High

Synopsis

The host is running a version of cURL/libcurl that is vulnerable to an unspecified attack vector.

Description

Versions of cURL and libcurl prior to 7.48.0 are affected by an integer overflow condition in the 'curlx_tvdiff()' function in 'lib/timeval.c'. The issue is triggered as user-supplied input is not properly validated when handling 'timeval'. This may allow a context-dependent attacker to have an unspecified impact.

Solution

Upgrade to cURL/libcurl 7.48.0 or later.