Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

MariaDB Server 10.1.x < 10.1.18 Multiple DoS

High

Synopsis

The remote database server is affected by multiple Denial of Service (DoS) attack vectors.

Description

The version of MariaDB installed on the remote host is 10.1.x prior to 10.1.18, and is affected by multiple DoS vulnerabilities :

- A flaw exists in the 'my_cop_fix_mb()' function that is triggered during the handling of queries for I_S and P_S tables. This may allow an authenticated attacker to crash the database. (OSVDB 144947) - A flaw exists in the 'qc_info_fill_table()' function in 'plugin/qc_info/qc_info.cc' that is triggered during the handling of 'SELECT' queries. This may allow an authenticated attacker to crash the database. (OSVDB 145168) - A flaw exists in the 'Prepared_statement::execute_loop()' function in 'sql/sql_prepare.cc' that is triggered during the handling of a specially crafted 'PREPARE' statement. This may allow an authenticated attacker to crash the database. (OSVDB 145169) - A flaw exists in the 'Item_sum_field' class in 'sql/item_sum.h' that is triggered during the handling of a specially crafted query. This may allow an authenticated attacker to crash the database. (OSVDB 145171) - A flaw exists in the 'fix_length_and_dec()' function in 'sql/item_strfunc.cc' that is triggered when handling modified arguments. This may allow an authenticated attacker to crash the database. (OSVDB 145172)

Solution

Upgrade to version 10.1.18 or later.