Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

MariaDB Server 10.2.x < 10.2.2 DoS

Medium

Synopsis

The remote database server is affected by a Denial of Service (DoS) attack vector.

Description

MariaDB is a community-developed fork of the MySQL relational database. The version of MariaDB installed on the remote host is 10.2.x earlier than 10.2.2, and is therefore affected by a flaw in 'sql/item_subselect.cc' that is triggered during the handling of specially crafted queries for non-existent functions. This may allow an authenticated attacker to crash the database. (OSVDB 143736)

Solution

Upgrade to version 10.2.2 or later.