Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

phpMyAdmin 4.4.15.x < 4.4.15.7 / 4.6.x < 4.6.3 Multiple Vulnerabilities

Medium

Synopsis

The remote web server contains a version of phpMyAdmin that is affected by multiple vulnerabilities.

Description

Versions of phpMyAdmin 4.4.15.x prior to 4.4.15.7, and 4.6.x prior to 4.6.3 are unpatched, and therefore affected by the following vulnerabilities :

- A flaw exists that may allow carrying out an SQL injection attack. The issue is due to the 'libraries/central_columns.lib.php' script not properly sanitizing user-supplied input when handling database names. This may allow a remote attacker to inject or manipulate SQL queries in the back-end database, allowing for the manipulation or disclosure of arbitrary data. Note that exploitation requires the existence of a controluser configured in config.inc.php. (OSVDB 140414) - A flaw exists that allows a cross-site scripting (XSS) attack. This flaw exists because the 'libraries/server_privileges.lib.php' script does not validate input to the 'ssl_cipher', 'x509_issuer', or 'x509_subject' parameters before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server. (OSVDB 140504) - A flaw exists that allows a reflected XSS attack. This flaw exists because the 'js/console.js' script does not validate input to server error messages before returning it to users. This may allow a context-dependent attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server. (OSVDB 140505) - A flaw exists that allows attack. This flaw exists because the 'js/functions.js' script does not validate input to database names before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server. (OSVDB 140506) - A flaw exists that allows attack. This flaw exists because the 'libraries/server_privileges.lib.php' script does not validate input to user groups before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server. (OSVDB 140507) - A flaw exists that allows attack. This flaw exists because the 'libraries/DBQbe.class.php' script does not validate input to saved search names before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server. (OSVDB 140508)

Solution

Upgrade to phpMyAdmin version 4.6.3 or later. If 4.6.3 cannot be obtained, version 4.4.15.7 has also been patched for these vulnerabilities.