Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

MediaWiki < 1.19.20 / 1.22.12 / 1.23.5 Multiple Vulnerabilities

Low

Synopsis

The remote web server is running a PHP application that is out of date and vulnerable to multiple cross-site scripting (XSS) attack vectors

Description

The version of MediaWiki installed is 1.19.x earlier than 1.19.20, 1.22.x earlier than 1.22.12, or 1.23.x earlier than 1.23.5. Therefore, it is affected by the following XSS vulnerabilities :

- A flaw exists that allows a XSS attack. This flaw exists because the 'includes/OutputPage.php' script does not restrict JavaScript code embedded within CSS content before returning it to users. This may allow an attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server. (CVE-2013-7444) - A flaw exists because the 'includes/OutputPage.php' script does not restrict JavaScript code embedded within CSS content before returning it to users. This may allow an attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server. (CVE-2014-7295)

Solution

Upgrade to MediaWiki version 1.23.5. If 1.23.x cannot be obtained, versions 1.22.12, and 1.19.20 have also been patched for these vulnerabilities.