Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

phpMyAdmin 4.0.10.x < 4.0.10.16 / 4.4.15.x < 4.4.15.7 / 4.6.x < 4.6.3 Multiple Vulnerabilities

High

Synopsis

The remote web server contains a version of phpMyAdmin that is affected by multiple vulnerabilities.

Description

Versions of phpMyAdmin 4.0.10.x prior to 4.0.10.16, 4.4.15.x prior to 4.4.15.7, and 4.6.x prior to 4.6.3 are unpatched, and therefore affected by the following vulnerabilities :

- A flaw exists in the 'libraries/Header.class.php' script that is triggered during the handling of transformations. This may allow a context-dependent attacker to gain access to authentication token information, which can facilitate CSRF attacks. (OSVDB 140495) - A flaw within the table search and replace feature is triggered by the unsafe passing of parameters to the 'preg_replace()' function. This may allow an authenticated remote attacker to potentially execute arbitrary code. (OSVDB 140496) - A flaw exists that allows a reflected cross-site scripting (XSS) attack. This flaw exists because the 'examples/openid.php' script does not validate input when handling error messages before returning it to users. This may allow a context-dependent attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server. (OSVDB 140498) - A flaw in Example OpenID Authentication and Setup scripts may allow a remote attacker to disclose the software's installation path. While such information is relatively low risk, it is often useful in carrying out additional, more focused attacks. (OSVDB 140499) - A flaw in the 'js/get_scripts.js.php' script is triggered during the handling of the 'scripts' parameter when loading a crafted JavaScript file. This may allow a remote attacker to cause a denial of service. (OSVDB 140500) - A flaw within the 'setup/frames/index.inc.php' script may allow an authenticated remote attacker to access the program on a non-HTTPS connection and inject arbitrary 'BBCode'. (OSVDB 140503) - A flaw exists that allows a cross-site scripting (XSS) attack. This flaw exists because the 'libraries/build_html_for_db.lib.php' script does not validate input to translated strings before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server. (OSVDB 140509) - A flaw exists that allows an XSS attack. This flaw exists because the program does not validate input to binary log names before returning it to users. This may allow an authenticated remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server. (OSVDB 140510) - A flaw exists that allows an XSS attack. This flaw exists because multiple transformation plugins do not validate input before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server. (OSVDB 140511) - A flaw exists that allows a reflected XSS attack. This flaw exists because the 'js/ajax.js' script does not validate input when rendering AJAX errors before returning it to users. This may allow a context-dependent attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server. (OSVDB 140512) - A flaw exists that allows an XSS attack. This flaw exists because the 'js/get_image.js.php' script does not validate input to image display attributes before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server. (OSVDB 140513) - A flaw exists that allows an XSS attack. This flaw exists because the 'TextLinkTransformationsPlugin.class.php' script improperly allows JavaScript links that are not sanitized before being returned to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server. (OSVDB 140514) - A flaw exists (OSVDB 140515) - A flaw exists that allows an XSS attack. This flaw exists because the 'js/tbl_chart.js' script does not validate input to chart columns before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server. (OSVDB 140516) - A flaw exists that allows an XSS attack. This flaw exists because the 'libraries/TableSearch.class.php' script does not validate input to the 'criteriaColumnTypes' POST parameter before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server. Note that in the 4.6.x branch, the vulnerable script name is templates/table/search/rows_zoom.phtml. (OSVDB 140517)

Solution

Upgrade to phpMyAdmin version 4.6.3 or later. If 4.6.3 cannot be obtained, versions 4.4.15.7 and 4.0.10.16 have also been patched for these vulnerabilities.