Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Apache Tomcat 7.0.x < 7.0.68 / 8.0.x < 8.0.32 Multiple Vulnerabilities

Medium

Synopsis

The remote web server is missing an Apache Tomcat patch update.

Description

Apache Tomcat 7.0.x before 7.0.68 or 8.0.x before 8.0.32 is affected by multiple vulnerabilities :

- A flaw exists that is triggered as the 'ResourceLinkFactory.setGlobalContext()' method is accessible to web applications even when run under a security manager. This may potentially allow a context-dependent attacker to inject a malicious global context and read and write data owned by other web applications. (CVE-2016-0763) - A flaw exists in the index page of the Manager and Host Manager applications that is triggered when issuing redirects in response to unauthenticated requests to the root of the web application. This may allow a remote attacker to gain access to CSRF token information stored in the index page. (CVE-2015-5351)

Solution

Update to Apache Tomcat version 8.0.32 or later. If version 8.0.x cannot be obtained, version 7.0.68 is also patched for these vulnerabilities.