Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Moodle 2.0.x < 2.0.9 / 2.1.x < 2.1.6 / 2.2.x < 2.2.3 Multiple Vulnerabilities

Medium

Synopsis

The remote web server is hosting a web application that is vulnerable to multiple attack vectors.

Description

The remote web server hosts Moodle, an open-source course management system. Versions of Moodle 2.0.x prior to 2.0.9, 2.1.x prior to 2.1.26, or 2.2.x prior to 2.2.3 are exposed to the following vulnerabilities :

- A flaw exists that allows students to edit pre-existing Database activity entries after the activity had entered a read-only period. (CVE-2012-2358) - A privilege escalation flaw exists which could be triggered by an error that allowed non-editing teachers to redefine the abilities of their account. This may allow an attacker to gain escalated privileges. (CVE-2012-2359) - A cross-site scripting (XSS) vulnerability exists in the Wiki. Specifically, this flaw exists because the application does not validate input passed via wiki page titles before returning it to the user. This may allow a user to create a specially crafted URL that would execute arbitrary script code in a user's browser within the trust relationship between their browser and the server. (CVE-2012-2360) - A cross-site scripting (XSS) vulnerability exists in Web services. Specifically, this flaw exists because the application does not validate the 'name' parameter upon submission to the 'admin/webservice/service.php' script. (CVE-2012-2361) - A flaw exists that allows a remote cross-site scripting (XSS) attack. This flaw exists because the application does not validate certain input upon submission to the 'blog/index.php' script. This may allow a user to create a specially crafted URL that would execute arbitrary script code in a user's browser within the trust relationship between their browser and the server. (CVE-2012-2362) - A flaw exists that may allow an attacker to carry out an SQL injection attack. The issue is due to certain input when adding calendar events not being properly sanitized before it is used in SQL queries. This may allow an attacker to inject or manipulate SQL queries in the back-end database, allowing for the manipulation or disclosure of arbitrary data. (CVE-2012-2363) - A cross-site scripting (XSS) vulnerability in the 'download all' function. This flaw exists because the send_temp_file() function does not validate certain input passed via 'download all' before returning it to the user. (CVE-2012-2364) - A cross-site scripting (XSS) vulnerability affects the 'idnumber' parameter in the script '/cohort/edit.php'. (CVE-2012-2365) - A flaw where access to the new calendar entry page is not properly restricted. This may allow an attacker to create arbitrary calendar entries. (CVE-2012-2367)

Solution

Upgrade to Moodle version 2.2.3. If version 2.2.x cannot be obtained, versions 2.0.9 and 2.1.3 are also patched for these vulnerabilities.