icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Safari < 6.1.5 / 7.0.5 Multiple Vulnerabilities

Medium

Synopsis

The remote host contains a web browser that is affected by multiple security vulnerabilities.

Description

The remote host has Safari installed that is older than 6.1.4 or 7.0.4, and is thus unpatched for the following WebKit vulnerabilities :

- Multiple memory corruption issues within WebKit, which were addressed through improved memory handling (CVE-2014-1325, CVE-2014-1340, CVE-2014-1362, CVE-2014-1363, CVE-2014-1364, CVE-2014-1365, CVE-2014-1366, CVE-2014-1367, CVE-2014-1368, CVE-2014-1382) - URL spoofing vulnerability due to improper encoding of domain names (CVE-2014-1345) - Information disclosure vulnerability wherein URLs dragged between windows could allow disclosure of local file content (CVE-2014-1369)

Solution

Upgrade to Safari 7.0.5 or later. If version 7.0.x is not available, version 6.1.5 is also patched for these issues.