icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

OpenSSH < 6.6 Remote Restriction Bypass Vulnerability

Low

Synopsis

The remote SSH service may be affected by a restriction bypass vulnerability.

Description

Versions of OpenSSH server before 6.6 are unpatched for a restriction bypass vulnerability related to wildcard usage in the 'AcceptEnv' configuration setting within sshd_config. This could be leveraged by an attacker to bypass environment restrictions via a specially crafted request.

Note: PVS has solely relied on the banner of the SSH client to perform this check. Any backported patches or workarounds such as recompiling or edited configurations are not observable through the banner.

Solution

Upgrade to OpenSSH version 6.6 or later.