Apple Quicktime 7.7.5 Multiple Vulnerabilities

Medium

Synopsis

The version of QuickTime on the remote machine is affected by multiple code execution vulnerabilities.

Description

Versions older than Quicktime 7.7.5 contain the following vulnerabilities:

- Multiple buffer overflow vulnerabilities, which can be leveraged by an attacker to execute arbitrary code or application termination (2014-1246, CVE-2014-1248, CVE-2014-1249)

- An out-of-bounds byte swapping issue in the handling of 'ttfo' elements, which can be leveraged by an attacker to execute arbitrary code or application termination (CVE-2014-1250)

- A signedness issue in the handling of 'stsz' atoms, which can be leveraged by an attacker to execute arbitrary code or application termination (CVE-2014-1245)

- A memory corruption issue when handling the 'dref' atoms, which can be leveraged by an attacker to execute arbitrary code or application termination (CVE-2014-1247)

Solution

Users of OS X Mavericks (v10.9) should upgrade to 10.9.2, which includes the Quicktime 7.7.5 update. All others should upgrade to version 7.7.5 or later.