icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Oracle GlassFish Server <= 3.1.1 Multiple Denial-of-Service Vulnerabilities

Medium

Synopsis

Oracle GlassFish Server is prone to a denial-of-service vulnerability.

Description

Oracle GlassFish Server versions <= 3.1.1 are prone to multiple vulnerabilities, including a denial-of-service vulnerability as well as an unspecified vulnerability related to Web Container that could affect server availability. The denial-of-service issue occurs due to an error during hashing form posts and updating a hash table. Specially crafted forms in HTTP POST requests can trigger hash collisions resulting in high CPU consumption. An attacker can exploit this issue by sending specially crafted forms in HTTP POST requests.

Solution

Ensure that server modules and applications are up to date with the latest plugins. Apply the vendor's updates or upgrade to a later version.