Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Rockwell Automation/Allen-Bradley MicroLogix 1400 SNMP Remote Privilege Escalation

High

Synopsis

A vulnerable MicroLogix 1400 programmable logic controller (PLC) has been detected.

Description

Rockwell Automation/Allen-Bradley MicroLogix 1400 programmable logic controllers (PLCs) contain an undocumented, high privileged SNMP community string. This may allow an unauthorized remote attacker to make changes to the device's configuration or update the firmware.

Solution

Currently, there are no known upgrades or patches to correct this vulnerability. It is possible to temporarily mitigate the flaw by implementing the following workaround :\n\n - Restrict SNMP access, such as through the use of a firewall, only to authorized access, or\n - Use the "RUN" keyswitch setting to prevent unauthorized firmware update operations and configuration changes.