icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Flash Player <= 10.3.183.16 / 11.1.102.63 Multiple Memory Corruption Vulnerabilities (APSB12-07)

High

Synopsis

The remote host contains a browser plug-in that is affected by multiple memory corruption vulnerabilities

Description

The remote host has Adobe Flash Player installed.

Versions of Flash Player 10.x equal to or earlier than 10.3.183.16 or 11.x equal to or ealier than 11.1.102.63 are potentially affected by several critical memory corruption vulnerabilities :

- Memory corruption vulnerabilities related to URL security domain checking. (CVE-2012-0772)

- A flaw in the NetStream Class that could lead to remote code execution. (CVE-2012-0773)

- Two Flash Player memory corruption vulnerabilities related to the Google Chrome interface. (CVE-2012-0724, CVE-2012-0725)

By tricking a victim into visiting a specially crafted page, an attacker may be able to utilize these vulnerabilities to execute arbitrary code subject to the users' privileges

Solution

Upgrade to Flash Player 10.3.183.18 / 11.2.202.228 or later.