icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Oracle Java JDK / JRE / SE Multiple Vulnerabilities (April 2013 CPU)

Synopsis

The remote Windows host contains a programming platform that is affected by multiple vulnerabilities

Description

The version of Oracle (formerly Sun) Java Runtime Environment (JRE) 7.x installed on the remote host is earlier than Update 21. It is therefore, potentially affected by the following security issues in the following components :

- 2D

- AWT

- Bean

- Deployment

- HotSpot

- ImageIO

- Install

- JavaFX

- JAXP

- JMX

- Libraries

- Networking

- RMI

Solution

Update to JDK / JRE 7 Update 21 or later and remove any affected versions.