icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

PostgreSQL < 8.3.23 / 8.4.16 / 9.0.12 / 9.1.8 / 9.2.3 Denial of Service

Medium

Synopsis

The remote database server is vulnerable to a denial of service vulnerability.

Description

Versions of PostgreSQL earlier than 8.3.23, 8.4.16, 9.0.12, 9.1.8, 9.2.3 and are potentially affected by a denial of service vulnerability due to a flaw in the enum_recv() functin of 'backend/utils/adt/enum.c'. By exploiting this flaw, a remote attacker could crash the affected application

Solution

Upgrade to PostgreSQL 8.3.23 / 8.4.16 / 9.0.12 / 9.1.8 / 9.2.3 or later.