icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Flash Player <= 10.3.183.43 / 11.5.502.110 Multiple Vulnerabilities (APSB12-27)

High

Synopsis

The remote host contains a browser plug-in that is affected by multiple vulnerabilities.

Description

The remote host has Adobe Flash Player installed.

Versions of Flash Player 11.x equal to or earlier than 11.5.502.110, or 10.x equal to or earlier than 10.3.183.43 are affected by multiple vulnerabilities:

- An unspecified error exists that can allow a buffer overflow and arbitrary code execution. (CVE-2012-5676)

- An unspecified error exists that can allow an integer overflow and arbitrary code execution. (CVE-2012-5677)

- An unspecified error exists that can lead to memory corruption and arbitrary code execution. (CVE-2012-5678)

Solution

Upgrade to Flash Player 10.3.183.48 / 11.5.502.135 or later.