icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Apple iOS < 4.2.10 / 4.3.x < 4.3.5 Data Security Certificate Verification Vulnerability

High

Synopsis

The remote host is affected by a security bypass vulnerability.

Description

According to its banner, the remote Apple iOS device is affected by a security bypass vulnerability due to a certificate chain validation issue during the handling of X.509 certificates. Versions of Apple iOS less than version 4.2.10, or 4.3.x prior to 4.3.5 are potentially affected by this security bypass vulnerability.

Solution

Upgrade to Apple iOS 4.2.10, 4.3.5, or later.