Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

IBM DB2 9.7 < 9.7 Fix Pack 3 Multiple Vulnerabilities

Critical

Synopsis

The remote IBM DB2 database server is affected by multiple vulnerabilities.

Description

Versions of IBM DB2 9.7 earlier than Fix Pack 3 are potentially affected by multiple vulnerabilities :

- When privileges on a database object are revoked from PUBLIC, the dependent functions are not marked INVALID. As a result, users with execute privilege on the function are still able to call it successfully. (IC68015) - If a compound SQL (compiled) statement has been issued by a user that is properly authorized, this is cached in the dynamic SQL cache. Once cached, this same query can be executed by an user if that user has the proper authority. (IC70406) - Multiple buffer overflow vulnerabilities exist in the DB2 Administrative Server (DAS). (IC70539, IC72029)

Solution

Upgrade to IBM DB2 9.7 Fix Pack 3 or higher.