Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

IBM DB2 9.1 < 9.1 Fix Pack 10 Multiple Vulnerabilities

Critical

Synopsis

The remote IBM DB2 database server is affected by multiple vulnerabilities.

Description

Versions of IBM DB2 9.1 earlier than Fix Pack 10 are potentially affected by multiple vulnerabilities :

- Multiple buffer overflow vulnerabilities exist in the DB2 Administrative Service (DAS) which could lead to a denial-of-service, or the execution of arbitrary code. (IC69986, IC71203) - Users continue to have privilege to execute a non-DDL statement after their DBADM authority has been revoked. (IC66811)

Solution

Upgrade to IBM DB2 9.1 Fix Pack 10 or higher.