icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Zabbix < 1.6.6 Null Pointer Dereference DoS

Medium

Synopsis

The remote host is vulnerable to denial-of-service attack.

Description

The remote host is running Zabbix, an IT monitoring service. The installed version of Zabbix is earlier than 1.6.6. Such versions are potentially affected by a Null Pointer Dereference vulnerability in the 'process_trap()' function of the 'zabbix_server/trapper/trapper.c' source file. An attacker can exploit this flaw to crash the affected service.

Solution

Upgrade to Zabbix 1.6.6 or later.