Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

IBM DB2 9.1 < 9.1 Fix Pack 6 Multiple Vulnerabilities

High

Synopsis

The remote IBM DB2 database server is affected by multiple vulnerabilities.

Description

According to its version, the installation of IBM DB2 9.1 on the remote host is affected by one or more of the following vulnerabilities :

- An unspecified error in 'SQLNLS_UNPADDEDCHARLEN()' may lead to a segmentation fault in DB2 server (LI73364). - DB2 does not mark inoperative or drop views and triggers if the definer cannot maintain the objects (IZ22306). - Password-related connection string keyword values may appear in trace output (IZ23915).

Solution

Apply IBM DB2 Version 9.1 Fix Pack 6 or higher.