icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Ruby on Rails < 2.1.1 Active Record Multiple Parameter SQL Injection

High

Synopsis

The remote host is vulnerable to a SQL injection attack.

Description

The remote server is running the Ruby on Rails web application. This version of Rails is reported to be vulnerable to a flaw in the way that it handles ':offset' and ':limit' parameters. An attacker exploiting these flaws would only require the ability to send malformed requests to the application. Successful exploitation would result in the attacker executing arbitrary SQL commands on the database used by Ruby on Rails.

Solution

Upgrade to version 2.1.1 or higher.