icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Snitz Forum < 3.4.0.07 active.asp BuildTime Parameter SQL Injection

High

Synopsis

The remote host is vulnerable to a SQL injection attack.

Description

The remote host appears to be running Snitz Forum, a web forum application implemented in ASP. This version of Snitz is reported to be vulnerable to a SQL injection flaw within the 'active.asp' script. An attacker exploiting this flaw would send specially formed HTTP queries to the active.asp script. These queries would include SQL statements that would ultimately be executed on the database utilized by Snitz.

Solution

Upgrade to version 3.4.0.07 or higher.