icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

Squid < 2.6.STABLE18 Update Reply Processing DoS

Medium

Synopsis

The remote proxy server is prone to a denial of service attack.

Description

According to its banner, the version of the Squid proxy caching server installed on the remote host is older than 2.6.STABLE17. Such versions reportedly use incorrect bounds checking when processing some cache update replies. A client trusted to use the service may be able to leverage this issue to crash the application, thereby denying service to legitimate users.

Solution

Either upgrade to version 2.6.STABLE18 or higher or patch according to vendor recommendations.