icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons icons_061

IBM DB2 9 < Fix Pack 3 / 8 < Fix Pack 15 Multiple Vulnerabilities

Medium

Synopsis

The remote IBM DB2 database server is affected by multiple vulnerabilities.

Description

According to its version, the installation of IBM DB2 on the remote host is affected by one or more of the following vulnerabilities :

- A local user may be able to overwrite arbitrary files, create arbitrary world-writeable directories, or gain root privileges via symlink attacks or specially-crafted environment variables. - A user may be able to continue to execute a method even once privileges for the method have been revoked (IY88226, version 8 only). - There is an unspecified vulnerability related to incorrect authorization routines (JR25940, version 8 only). - There is an unspecified vulnerability in 'AUTH_LIST_GROUPS_FOR_AUTHID' (IZ01828, version 9.1 only). - There is an unspecified vulnerability in the 'db2licm' and 'db2pd' tools (IY97922 / IY97936). - There is an unspecified vulnerability involving 'db2licd' and the 'OSSEMEMDBG' and 'TRC_LOG_FILE' environment variables (IY98011 / IY98101). - There is a buffer overflow involving the 'DASPROF' environment variable (IY97346 / IY99311). - There is an unspecified vulnerability that can arise during instance and FMP startup (IZ01923 / IZ02067).

Note that there is currently insufficient information to determine to what extent the first set of issues overlaps the others.

Solution

Apply IBM DB2 Version 9 Fix Pack 3 / 8 Fix Pack 15 or higher.